Problem: “Dependecy Error” upgrading ESXi 6.0 to Update 2

Trying to upgrading ESXi 6 to update 2 with esxcli we received this error:

[DependencyError]
VIB VMware_bootbank_esx-base_6.0.0-2.34.xxxxx requires vsan << 6.0.0-2.35, but the requirement cannot be satisfied within the ImageProfile. VIB VMware_bootbank_esx-base_6.0.0-2.34.xxxxxx requires vsan >= 6.0.0-2.34, but the requirement cannot be satisfied within the ImageProfile.
Please refer to the log file for more details.

There is a KB from VMware that explain why.

This is what i did.

To check the profiles that are inside the ZIP

esxcli software sources profile list -d /vmfs/volumes/datastore1/update-from-esxi6.0-6.0_update02.zip

 

Then update the profile like explained on VMware KB:

esxcli software profile update -p ESXi-6.0.0-20160302001-standard -d /vmfs/volumes/datastore1/update-from-esxi6.0-6.0_update02.zip

 

Check the results with:

esxcli software profile get
Advertisements

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s